Building a Basic Neutron Network via the OpenStack CLI

Introduction

Within this article, we will detail the steps required to build a simple networking topology in Neutron using the OpenStack CLI.

Topology

Our topology (Figure 1) will consist of an L3 router, an external network, a tenant network and a range of floating IPs. Our external network will be a VLAN based network and segment traffic using a VLAN tag of 50.

https://www.packetcoders.io/content/images/2018/06/OpenStackCLI-v0.2--1-.png

Figure 1 - Topology

Neutron Components

Before we dive into the configuration steps, lets quickly look at each of the components that we will use to build our topology,

https://www.packetcoders.io/content/images/2018/07/networktop.png

Figure 2 - Network Topology and Components

Physical Gateway

Before we start with configuring Neutron, the physical gateway (in our case a Cisco ASA5505) is configured to provide remote connectivity. Within our configuration, we simply configure a trunk and the corresponding VLAN (i.e the provider segment aka VLAN 50).

interface Ethernet0/4
 description ## OPENSTACK TRUNK ##
 switchport trunk allowed vlan 50
 switchport trunk native vlan 1
 switchport mode trunk
 speed 100
 duplex full
!
interface Vlan50
 nameif OPENSTACK-EXTERNAL-NET
 security-level 100
 ip address 172.29.50.1 255.255.255.0

External Network